Looking for the Mango Mobile Apps?

Look no further! Just click here to get started.

The Mango Languages app is compatible with:

  • Apple devices (iPhone, iPad, iPod touch) running iOS 8.0 or higher
  • Android phones and tablets running Android 4.1 or higher
  • Kindle Fire 2nd Gen and above, Fire HD, and Fire HDX tablets
Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk