Why won't my course load?

You may just need to clear your cache! When your cache/temporary internet files is full, it can slow down your computer and time Mango out before it fully loads. To access the lessons, please be sure that you have up-to-date versions of your web browser and Adobe Flash Player (at least version 10.3 please!), as well as a high-speed internet connection. 

We always recommend using the most up-to-date version of your web browser to ensure you get the full Mango experience, however, here are the minimum browser versions you are welcome to use and still have access to our courses:

Firefox: 25.0 and +

Chrome: 31.0 and +

Safari: 6.0.5 and +

IE: 10.0 and +

If you're unsure which version of Adobe Flash Player you have, please visit the Flash Diagnostic page to check your installation.  Make sure that the version number displayed is at least 10.3. Please visit the Adobe Flash Homepage to install or upgrade Flash.

Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk